D-Bug & Automation Forum
D-Bug & Automation Forum >> ST/STE/MSTE/Falcon/TT Patches >> Problem with Turrican
https://d-bug.mooo.com/dbugforums/cgi-bin/yabb2/YaBB.pl?num=1228156767

Message started by DaNyL on 01.12.08 at 18:39:26

Title: Problem with Turrican
Post by DaNyL on 01.12.08 at 18:39:26
Hi everyone!
First of all: a huge Thank You to D-Bug for releasing Turrican ULSv3!
... but I have a problem running it on my machine.
My Falcon is a standard 4MB, connected to the TV by TV-out.
The Rainbow Arts Intro is just like on ST, then the Turrican voice starts pitched higher (on 16Mhz) or way lower (on 8Mhz) than ST and then the Screen starts to distort; seems like the Falcon isn't in 15khz/TV land anymore by then.
Any ideas? I use a clean boot, nothing running but HD-driver.
EDIT: I use TOS 4.04
Greetz,
Danyl

Title: Re: Problem with Turrican
Post by Shw on 01.12.08 at 20:10:06
that's really strange.

I have a bog standard 4mb Falcon, no VDI or anything like that. and running HDDriver... what size cache have you got with HDDriver? you need to have a minimum cache use 999 and 999 in general options of Hddriver and see if that helps.

Cheers
Shw

Title: Re: Problem with Turrican
Post by DaNyL on 01.12.08 at 20:59:07
thanks; but it still has the video problems.
It seems that Turrican IS running; I can hear the title tune after pressing fire and waiting; but the video output seems to be VGA instead of TV, at least the screen seems to be trying to sync to a higher hsync.
Would it be possible to get a version which ignores Monitor information and forces the falcon to be running at tv-out? Or am I thinking wrong and there no custom screen initialisation?
(I start the game from ST-low; and after the Rainbow Arts logo the sync problem starts to appear)
Thanks,
Danyl

EDIT: made a quick capture from my television:
http://dawork.synchronus.de/share/01122008.mp4

Title: Re: Problem with Turrican
Post by CJ on 01.12.08 at 21:25:04
Sounds like the 320x244 RGB code isn't working for you.  That's not something I can test as my falcon isnt plugged into a TV.

Try pressing Fire when the music starts and it should flip back to 320x200 for the game.

Title: Re: Problem with Turrican
Post by DaNyL on 01.12.08 at 21:34:12
hmm. never tried that ^^
in-game works perfectly; so it's the TV-Out in that resolution.
Thanks to all! I'll build a RGB-cable then.
Greetings,
Danyl

Title: Re: Problem with Turrican
Post by simonsunnyboy on 02.12.08 at 20:27:06
I can confirm this problem while in RGB mode.
Only the title screen seems affected as mentioned before.
Well done  :) - I actually never played the first part much. Maybe I should do so for STOT now?  ;D

Title: Re: Problem with Turrican
Post by insane on 27.09.14 at 18:28:54
Sorry to reopen this thread after all these years - but I've fixed my issue by patching the crack.

http://dawork.synchronus.de/filez/t1f030patch.zip

I've patched the RGB Routines to work on my monitor and the VGA routines to use 50hz instead of 60hz.

Hope that this can help somebody else.
DaNyL / insane of tscc

p.s.: i didn't get any password recovery mail - is there a problem with the system?

Title: Re: Problem with Turrican
Post by ggn on 30.09.14 at 12:34:45

insane wrote on 27.09.14 at 18:28:54:
Sorry to reopen this thread after all these years - but I've fixed my issue by patching the crack.

http://dawork.synchronus.de/filez/t1f030patch.zip

I've patched the RGB Routines to work on my monitor and the VGA routines to use 50hz instead of 60hz.

Hope that this can help somebody else.
DaNyL / insane of tscc


Good stuff, will download and test on my Falcon when I find the time! (and then update the archive file!)


insane wrote on 27.09.14 at 18:28:54:
p.s.: i didn't get any password recovery mail - is there a problem with the system?


Yeah, the server this forum is on doesn't have email sending facilities - PM me the password you want to reset your old profile to if you like :).

D-Bug & Automation Forum » Powered by YaBB 2.6.0!
YaBB Forum Software © 2000-2021. All Rights Reserved.