D-Bug & Automation Forum
D-Bug & Automation Forum >> ST/STE/MSTE/Falcon/TT Patches >> Wings Of Death
https://d-bug.mooo.com/dbugforums/cgi-bin/yabb2/YaBB.pl?num=1228590106

Message started by simonsunnyboy on 06.12.08 at 19:01:46

Title: Wings Of Death
Post by simonsunnyboy on 06.12.08 at 19:01:46
I just tried the new WoD on my Falcon and  :D
This is awesome stuff and it left me speechless. It just works beautifully and the idea with the DSP music is really a feature not seen sofar!

This is really great stuff! :)

Title: Re: Wings Of Death
Post by Heavy Stylus on 10.12.08 at 11:15:47
Yeah - superb work!  Makes me really wish I had a Falcon..!

Title: Re: Wings Of Death
Post by wod on 13.12.08 at 12:31:33
Really great stuff guys. I am so glad I can play the game on my falcon AND from hard disk now. :-)

Unfortnately the AMIGA patch doesn't work on my machine. Whenever I start the extended version the game immediately freezes when the first level begins (e.g. the players ship appears). Normal version is working fine.

My configuration:

System: ATARI Falcon 030/ct63 but running in 030 mode
Cache Sizes: none, played the game from floppy
Memory: 14mb ST-RAM, FastRAM not activated
HD Driver used: 8.17 but not used, booted with ALT pressed
Options Selected in loader: infinite lives: n, infinite energy: n, AMIGA MUSIC: y

What you were doing: pressed space to start the game, intro screen (with dbug2008) appeared did nothing, then start screen appeared (with start sound: Wings of Death, hahaha), pressed space, "Please insert Disk B and press any key!", pressed space again, "Start new game", pressed fire button on joystick, "Loading and decrunching stage 1", "Push button to enter stage 1: Sagyr's castle", pushed joystick button again, computer freezes". :(

Any ideas?

Title: Re: Wings Of Death
Post by CJ on 13.12.08 at 13:09:59
We had that on one machine while testing... it turned out to be some driver that got loaded at boot time.

What I suggest for starters:

Go into HDDriver's utility and set CACHE SIZE to "999" (this disabled cache)

Then, clean out your auto folder and try running it again.  If you still have problems I can post an alternate loader that might fix it. The game truly is superb with TFMX music.

CJ


PS: Thanks for reading the RTFM page :)

Title: Re: Wings Of Death
Post by wod on 13.12.08 at 14:59:56

CJ wrote on 13.12.08 at 13:09:59:
We had that on one machine while testing... it turned out to be some driver that got loaded at boot time.

What I suggest for starters:

Go into HDDriver's utility and set CACHE SIZE to "999" (this disabled cache)

Then, clean out your auto folder and try running it again.  If you still have problems I can post an alternate loader that might fix it. The game truly is superb with TFMX music.

CJ


PS: Thanks for reading the RTFM page :)


;)

Thanks for replying so fast.

Set the caches to 999 but it didn't help.

And as I booted from floppy with ALTERNATE pressed there was neither a hddriver booted nor an AUTO folder program or any ACC involded.

So the idea of a different loader looks appealing to me.  ::)

wod

P.S.: TOS 4.04

P.P.S.: Tried it with my second falcon again and there after some struggles I finally got it running even with AMIGA sound on

System: TOS 4.04 ATARI Falcon 030/ab040 but running in 030 mode (once installed a switch Afterburner/030-mode)
Cache Sizes: none, played the game from floppy
Memory: 4mb ST-RAM, FastRAM not activated
HD Driver used: 8.17 but not used, booted with ALT pressed
Options Selected in loader: infinite lives: n, infinite energy: n, AMIGA MUSIC: y

What I recognized was that depacking took a lot longer than on my other falcon.

So thanks for your great work. Keep it goin'!  :)

Title: Re: Wings Of Death
Post by CJ on 13.12.08 at 23:18:41
Ok, I know what the problem is now but I have no idea *why*

It seems that ARJ's "Uncrunch" routine doesnt execute correctly on all Falcons for some reason.  The other machine it didnt work on was doing something similar until I moved the data files around in memory.

Anyway, I'll post a fully unpacked version later for you to try (Advantage: Loads quicker... Disadvantage: More space used)

CJ

Title: Re: Wings Of Death
Post by CJ on 13.12.08 at 23:57:24
Please try this version and let us know how you go along.

Everyone deserves some TFMX love this Christmas :)
WOD_UNPACKED.ZIP (Attachment deleted)

Title: Re: Wings Of Death
Post by wod on 14.12.08 at 14:10:35

CJ wrote on 13.12.08 at 23:57:24:
Please try this version and let us know how you go along.

Everyone deserves some TFMX love this Christmas :)


Tested it on my ct63 falcon and same as above, as soon as the game starts and the falcon tries to play the AMIGA tune the machine freezes.  :(

Had to test it from HD though (e.g. HD-Driver 8.17) cause the files didn't fit on a floppy disk.

BTW, I even tried a MP3 file with FalcAMP to make sure the hardware (DSP) isn't defective. The falcon plays the MP3 without any glitches (even in 030 mode).

Hope this helps a little bit.

wod

P.S.: I always test on RGB.

Title: Re: Wings Of Death
Post by CJ on 14.12.08 at 23:23:17
Then I'm stumped.

Do you have any other exotic hardware in there, like a PhantomS or anything? Is there any chance you could try on VGA?

Title: Re: Wings Of Death
Post by ggn on 15.12.08 at 07:53:34
Pardon me for butting in, but have you tried playing it without TFMX?

Title: Re: Wings Of Death
Post by wod on 15.12.08 at 08:50:20

ggn wrote on 15.12.08 at 07:53:34:
Pardon me for butting in, but have you tried playing it without TFMX?


Yes. I did. Works fine.  :) Only TFMX version freezes.

wod

Title: Re: Wings Of Death
Post by wod on 15.12.08 at 08:53:52

CJ wrote on 14.12.08 at 23:23:17:
Then I'm stumped.

Do you have any other exotic hardware in there, like a PhantomS or anything? Is there any chance you could try on VGA?


No. Stock falcon (except ct63 but you can switch it off), no clock patch, but SDMA patch applied (see rodolphe's website).

Today in the evening I am going to test it on VGA with this falcon. Keep you informed.

[Update: Tested the unpacked TFMX version and it works on VGA and even on my ct63 machine -> Great].

So thanks for this phantastic patch.

wod

D-Bug & Automation Forum » Powered by YaBB 2.6.0!
YaBB Forum Software © 2000-2021. All Rights Reserved.