D-Bug & Automation Forum
D-Bug & Automation Forum >> Coding/Hardware >> Partitioning a CF - no partitions found? SOLVED!

Message started by ggn on 14.09.09 at 16:30:38

Title: Partitioning a CF - no partitions found? SOLVED!
Post by ggn on 14.09.09 at 16:30:38
A few hours ago I installed a fresh new 4GB Compact Flash on my TT, using a scsi2ide & ide cf reader. All went fine and swell, HDdriver detected the card straight away, I partitioned it (for reference, 1st partition was 31mb GEM, and the rest were at most 511mb of types BGM, F32 and LNX), installed HDdriver on C: and rebooted.

Then I got a strange message: "No partitions found!"

WTF? I've done this countless times on my Falcon and it has worked flawlessly. I went on to try everything under the sun in HDDRUTIL, but still no go. Tried initialising the partitions, changing boot settings, nothing at all.

(note that I had done this in the past and may have encountered this before, but didn't remember how I solved it back then :)).

Anyway, to cut a long story short, here's the procedure I followed and worked 100%:

  • Booted HDdriver from floppy
  • Partitioned the CF
  • Rebooted the machine and held ALT (the point is that HDdriver is not loaded from the CF)
  • From GEM load hddriver from floppy (located in AUTO folder)
  • Copy the contents of the floppy in the CF (I created a folder called HDDRIVER just to keep it tidy)
  • Load HDDRUTIL.PRG from the CF
  • Install HDdriver from the menu (it'll ask for hddriver.sys, just point at it on the root dir - it should be there)
  • Do an auto-configuring, the CF should be detected, press OK.
  • Go to partition types and add GEM and BGM at the bottom of the dialog (well, that's just a precaution, but I did it anyway.
  • Reboot - HDdriver should boot from CF and list all the drives!

I have to admit, this post is mostly for my own reference, hope it's of use to anyone :)

D-Bug & Automation Forum » Powered by YaBB 2.6.0!
YaBB Forum Software © 2000-2021. All Rights Reserved.