D-Bug & Automation Forum
D-Bug & Automation Forum >> ST/STE/MSTE/Falcon/TT Patches >> Bugs I have found lately (All HD STEem/4mb/206)
https://d-bug.mooo.com/dbugforums/cgi-bin/yabb2/YaBB.pl?num=1318433907

Message started by MitchFrenzal on 12.10.11 at 15:38:26

Title: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 12.10.11 at 15:38:26
Cabal -  The soldier sprites don't show up (So it looks like you're being fired on from nowhere)

Crystal Kingdom Dizzy - Doesn't accept joystick input (Keyboard works fine though.)

Clever and Smart - Doesn't seem to start (This may just be me though.)

Fantasy World Dizzy - Doesn't seem to accept *any* input

Gobliins 1 - The protection check doesn't seem to be removed from the 00 loader.

Fire and Brimstone - The intro says it's Warzone. :)

Ishar 2 - Doesn't seem to load, Just white-screens.

Jim Power - Locks on the Loricels logo.

Live and let die - No joystick inputs again.

Microprose Grand Prix - Seems to crash after the protection check.


Will do from M onwards shortly. :)

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by CJ on 12.10.11 at 23:47:41
Not to sound like p-cock here, but it looks more like you have a configuration issue to have all those problems.

I've played several of those through completely on both my Falcon and my MSTE.

Given Microprose F1GP was the very first ULSv3.0 patch, it was tested for weeks before we released it on several configurations. I find it hard to believe there's a problem as obvious to spot as it crashing before the game starts!

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by Klapauzius on 13.10.11 at 09:29:27

MitchFrenzal wrote on 12.10.11 at 15:38:26:

Clever and Smart - Doesn't seem to start (This may just be me though.)


The dbug patch page says:
"Don't press any keys or move joystick until the game screen appears"
May be the reason?

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by Shw on 15.10.11 at 13:37:53
CKD, I'm sure you need the joystick in the mouse port.

Shw

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 16.10.11 at 12:00:19
Pretty much, This is just from running them a couple times in STEem/4mb/206, (I have another half to that list.) I just wondered why every time I go looking for info on other forums, It's usually full of people complaining about you. (rather than reporting it here, you'll find.)

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 16.10.11 at 12:01:12
Also, Will check solutions, Later. :)

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 16.10.11 at 12:23:04
And part 2. :)

Murder - Shows game over screen after first move

Navy Moves - Bombs (4) after music in intro

Predator 2 - No inputs at all

Pepsi Mad Mix - Locks on game start (This did this on my real ST back in the day off the menu too.)

Rainbow Islands - Constantly asks for the data disk

Spellbound Dizzy - Joystick inputs again

Silent Service 2 - Bombs (2) on picture

Spiderman - Wrecks after the intro

Torvak - Can't continue from the "press fire to continue" screen

This concludes the MF cup draw second round, All ties to be played on Sunday the 15th, blah, blah. ;)

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by Shw on 16.10.11 at 19:55:17
just tried Torvak in Steem with 2.06 and 4mb, fire does work... not sure what you're doing wrong?

Navy Moves - works fine, again Steem 2.06/4

there must be an underlying cause... as they're the only ones I've tried so far and both work?!

Could you post a vid of maybe Navy Moves on You-tube?

Shw

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by Klapauzius on 16.10.11 at 20:44:45
Mitch, what flavour, i.e. country version, of TOS 2.06 are you using in Steem?
I just ask because there were (or still are) some corrupt TOS images floating around the web.
For example, I never found a working TOS2.06UK.
I'd suggest trying another TOS image, just to be sure.

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 17.10.11 at 14:59:14
I am using 2.06UK. If you know of one that works, Point me in the right direction, Doesn't SHW use the same one?

Oh, CK-Dizzy, You were dead on, Clever and smart too.

F1GP. Isn't there a trick to the protection check, It always asks for the same word. I just don't know what it is. :)

Shw, I will try with navy moves. I hate youtube though. :/

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by Shw on 17.10.11 at 15:04:03
Isn't it "cars" I guess the d-bug menu will tell ya

Yep I use uk 2.06.

Shw

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 17.10.11 at 15:07:10
Hah, Thinking about it, I only have 1.02 and 2.06. :/

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by Klapauzius on 17.10.11 at 15:46:49
Mitch, you might try shw's TOS image, just to be sure yours hasn't got corrupted somehow.

Or, if you're not afraid of reading a bit of German, try the attached one, which I know is 100%. :)
https://d-bug.mooo.com/dbugforums/cgi-bin/yabb2/YaBB.pl?action=downloadfile;file=Tos206de.zip ( 127 KB | Downloads )

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 17.10.11 at 15:48:57
My German is terrible, (I took French.) But it can't do any harm, I suppose.

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 17.10.11 at 15:49:58
"Cars"? Maybe wants putting on the HD intro, So I don't look like an idiot. Wait. Scratch that. ;)

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by Shw on 17.10.11 at 17:59:07
here's my TOS 2.06


https://d-bug.mooo.com/dbugforums/cgi-bin/yabb2/YaBB.pl?action=downloadfile;file=TOS206.rar ( 118 KB | Downloads )

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 25.10.11 at 14:31:45
Don't think the TOS was to blame, But I've found the culprit for at least half of them, Sometimes my joypad sticks in the up position when idle. (I only realised this when playing with something with a joypad reader thingy.) So. Consider these off the list, (Unless you like to hold up during loading.)

The Dizzy games, Live and let die, Murder, Predator 2 and Torvak.

F1GP works fine, After working out the password.

Gobliins 1 - The answer to the protection is always "blue"

Navy moves - Seems to work if you turn the ramdisk on. (it's off as default.)

Hope that quells the alarm bells for a few moments. :)

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 25.10.11 at 17:24:07
Oh, And just for GG. I believe your Empire Strikes Back is the only on that works *properly* on STEem. Have a warm feeling on me. :)

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 30.10.11 at 19:15:32
For me, Of what's left on that list. Cabal seems the most broken. It's nothing to do with my joypad or TOS anymore. I tried a different version and the sprites work fine. Maybe a file missing or something?

Title: Re: Bugs I have found lately (All HD STEem/4mb/206)
Post by MitchFrenzal on 13.11.11 at 18:17:21
Oh, And the point of this thread, Was to prove that I'd actually tested them all on STEem, So next time I read "XYZ doesn't work on STEem, What sort of idiots are D-Bug?"
I have a fair idea if they are right or not. :)
(Other than that bloody joypad thing, That didn't help.)

D-Bug & Automation Forum » Powered by YaBB 2.6.0!
YaBB Forum Software © 2000-2021. All Rights Reserved.