Page Index Toggle Pages: 1 Send TopicPrint
Automation 450 (Read 866 times)
Shw
D-Bug member
*****
Offline


D-Bug member

Posts: 367
Location: Kingston Upon Hull
Joined: 22.02.07
Gender: Male
Automation 450
03.02.08 at 12:17:28
Print Post  
Whilst ripping the digi zak from Chambers of Shaolin I noticed Steem doesn't emulate the DMA correctly, due to this the digi tune plays way too slow.

Now I've found a fix for this..... so question.

Do I re-release 450 so the game works 100% in Steem (it works 100% already on REAL ST's) or should I let the Steem authors fix the emulator?
I know Sharaz Jek used to fix the odd Automation game for pacifiST in the old old days.

Shw
  
Back to top
 
IP Logged
 
CJ
D-Bug member
Reboot Member
*****
Offline


D-Bug Founder

Posts: 1205
Location: State of Confusion
Joined: 22.02.07
Gender: Male
Re: Automation 450
Reply #1 - 03.02.08 at 18:02:00
Print Post  
I'd say let the Steem guys fix it - the more "bugs" they have that are reproducable, the better and easier it is for them to fix.

However, Steem is rapidly becoming "abandonware" ......

I'd still say leave it... either let the Steem guys fix it, or wait for another emulator.
  

"With only one button, even drooling fucktards like Kizza can play our game!"
Back to top
 
IP Logged
 
Shw
D-Bug member
*****
Offline


D-Bug member

Posts: 367
Location: Kingston Upon Hull
Joined: 22.02.07
Gender: Male
Re: Automation 450
Reply #2 - 07.08.08 at 19:58:45
Print Post  
Ok, I'll leave it Smiley (unless people are desperate)

The Steem problem is that it doesn't set the DMA Sound Registers properly. The music works fine on a real STe.

Shw
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
 
  « Board Index ‹ Board  ^Top